RIP

RIP

در سناریوی زیر قصد داریم مسیریابی پویا را با استفاده از RIP در روتر ها تنظیم کنیم. همچنین فرض شده است که IP در اینترفیس ها در بخش تنظیم ip در اینترفیس تنظیم شده اند :

Scen3

ابتدا به تنظیمات روتر RIP با دستورات زیر وارد می‌شویم :

soodar1# conf t
soodar1(config)#
soodar1(config)# router rip
soodar1(config-router)#

اضافه کردن شبکه ها

می توان با استفاده از آدرس شبکه و هم چنین نام اینترفیس شبکه هایی که قرار است روی آن ها RIPng اجرا شود و با دیگر روتر ها صحبت کند مشخص کرد :

soodar1(config-router)# network 200.1.2.0/24
soodar1(config-router)# network 200.1.3.0/24

توزیع مسیرها

soodar1(config-router)# redistribute connected

اضافه کردن اینترفیس های passive

soodar1(config-router)# passive-interface ge2
soodar1(config-router)#end
soodar1# write

تنظیمات را به همین شکل برای soodar2 و soodar3 انجام می دهیم :

soodar2# conf t
soodar2(config)#
soodar2(config)# router rip
soodar2(config-router)# network 200.1.2.0/24
soodar2(config-router)# network 200.2.3.0/24
soodar2(config-router)# redistribute connected
soodar2(config-router)# passive-interface ge2
soodar2(config-router)#end
soodar2# write
------------------------------
soodar3# conf t
soodar3(config)#
soodar3(config)# router rip
soodar3(config-router)# network 200.2.3.0/24
soodar3(config-router)# network 200.1.3.0/24
soodar3(config-router)# redistribute connected
soodar3(config-router)# passive-interface ge2
soodar3(config-router)#end
soodar3# write

مشاهده جدول مسیریابی

با دستور زیر جدول مسیریابی تشکیل شده را مشاهده می کنیم که شبکه های 2.1.1.0 و 3.1.1.0 در روتر soodar1 توسط پروتکل RIP مسیریابی شده اند :

soodar1# sh ip fib 
Codes: K - kernel route, C - connected, S - static, R - RIP,
       O - OSPF, I - IS-IS, B - BGP, E - EIGRP, N - NHRP,
       T - Table, v - VNC, V - VNC-Direct, A - Babel, D - SHARP,
       F - PBR, f - OpenFabric,
       > - selected route, * - FIB route, q - queued route, r - rejected route

C>* 1.1.1.0/24 is directly connected, ge2, 00:04:19
R>* 2.1.1.0/24 [120/2] via 200.1.2.2, ge0, 00:04:13
R>* 3.1.1.0/24 [120/2] via 200.1.3.3, ge1, 00:04:15
C>* 200.1.2.0/24 is directly connected, ge0, 00:04:19
C>* 200.1.3.0/24 is directly connected, ge1, 00:04:19
R>* 200.2.3.0/24 [120/2] via 200.1.2.2, ge0, 00:04:13

بررسی عملکرد RIP

باید ارتباط شبکه ای 1.1.1.0 , 2.1.1.0 , 3.1.1.0 بوسیله پروتکل RIP برقرار شده باشد .



OSPF , EIGRP , RIP , IS-IS , BGP , OSPFv3 , RIPng