EIGRP

EIGRP

در این حالت از پروتکل EIGRP برای Routing استفاده می شود . فرض شده است که IP در اینترفیس ها در بخش تنظیم ip در اینترفیس تنظیم شده اند :

Scen3

soodar1 :
در این روتر در اینترفیس های ge0 , ge1 پروتکل EIGRP فعال شده است :

تنظیم EIGRP در اینترفیس

soodar1(config)# interface ge0  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

تنظیم EIGRP در اینترفیس ge1

soodar1(config)# interface ge1  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

اضافه کردن شبکه ها به تنظیمات EIGRP

soodar1(config-router)# network 200.1.2.0/24  
soosar1(config-router)# network 200.1.3.0/24    
soodar1(config-if) # end  
soodar1# write  

توزیع route ها توسط EIGRP

soodar1(config-router)# redistribute connected  

تنظیمات در بقیه روتر ها نیز مانند soodar1 خواهد بود.

soodar2 :
تنظیم EIGRP در اینترفیس ge0 :

soodar1(config)# interface ge0  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

تنظیم EIGRP در اینترفیس ge1 :

soodar1(config)# interface ge1  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

اضافه کردن شبکه ها به تنظیمات EIGRP :

soodar2(config)# router eigrp 10  
soodar2(config-router)# network 200.1.2.0/24     
soodar2(config-router)# network 200.2.3.0/24    
soodar2(config-if) # end  
soodar2# write  

توزیع route ها توسط EIGRP :

soodar2(config-router)# redistribute connected  

soodar3 :
تنظیم EIGRP در اینترفیس ge0 :

soodar1(config)# interface ge0  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

تنظیم EIGRP در اینترفیس ge1 :

soodar1(config)# interface ge1  
soodar1(config-if)# eigrp bandwidth 1000000  
soodar1(config-if)# exit  

اضافه کردن شبکه ها به تنظیمات EIGRP :

soodar3(config)# router eigrp 10  
soodar3(config-router)# network 200.1.3.0/24     
soodar3(config-router)# network 200.2.3.0/24   
soodar3(config-if) # end  
soodar3# write  

توزیع route ها توسط EIGRP :

soodar3(config-router)# redistribute connected  

پس از اعمال شدن تنظیمات کمی صبر می کنیم تا روتر ها با استفاده از پروتکل EIGRP جدول Routing را تشکیل
دهند .
سپس با استفاده از دستور زیر جدول Routing که با استفاده از پروتکل EIGRP تشکیل شده است را مشاهده می کنیم :

soodar1# sh ip eigrp topology  

یا
soodar1# sh ip fib  
Codes: K - kernel route, C - connected, S - static, R - RIP,
       O - OSPF, I - IS-IS, B - BGP, E - EIGRP, N - NHRP,
       T - Table, v - VNC, V - VNC-Direct, A - Babel, D - SHARP,
       F - PBR, f - OpenFabric,
       > - selected route, * - FIB route, q - queued route, r - rejected route

C>* 1.1.1.0/24 is directly connected, ge2, 00:00:16
E>* 2.1.1.0/24 [90/30720] via 200.1.2.2, ge0, 00:00:08
E>* 3.1.1.0/24 [90/30720] via 200.1.3.3, ge1, 00:00:08
C>* 200.1.2.0/24 is directly connected, ge0, 00:00:16
C>* 200.1.3.0/24 is directly connected, ge1, 00:00:16
E>* 200.2.3.0/24 [90/30720] via 200.1.2.2, ge0, 00:00:08
  *                         via 200.1.3.3, ge1, 00:00:08




OSPF , EIGRP , RIP , IS-IS , BGP , OSPFv3 , RIPng